Menu

Инсталиране на някои зависимости при специфични темплейти за фронтрнд, блог и електронна търговия

При инсталация на някой темплейти, като например http://www.odooshoppe.com/shop/product/tangy-e-commerce-theme-24 (https://www.odoo.com/apps/themes/8.0/website_ecommerce/), липсата на предварително инсталирани зависимости чупи дизайна (CSS+JS) на целия фронтенд. Проблема се рещава така:

  • sudo apt-get install curl
  • sudo apt-get install -y nodejs
  • sudo npm install -g npm (to update npm)
  • sudo npm install -g less less-plugin-clean-css

Или още по лесно:

sudo apt-get -y install curl npm && curl -sL https://deb.nodesource.com/setup | bash - && apt-get -y install nodejs && npm install -g npm && npm install -g less less-plugin-clean-css

 

Последно променена вСряда, 28 Септември 2016 01:09
  • Оценете
    (2 гласа)
  • Публикувана в Odoo 8
  • Прочетена 1396 пъти
администратор

Odoo (OpenERP) интегратор и администратор

Уеб сайт: www.openerp.bg

Оставете коментар

Моля убедете се, че всички задължътелни полета (маркирани със звезда) са попълнени. Не е разрешен HTML код.

нагоре

Вход или Регистрирай се